We are partially recovered from a service disruption caused by an AWS infrastructure issue in us-east-1. Most traffic is now flowing, but response times remain elevated. We expect full recovery within 30–60 min as systems normalize.
Posted May 07, 2026 - 19:04 PDT
Update
We are continuing to investigate this issue.
Posted May 07, 2026 - 18:07 PDT
Investigating
Core application is currently unavailable
Posted May 07, 2026 - 18:07 PDT
This incident affected: API Core Service, Credit Service, Offers Engine, SSO Service - Auth, and SSO Service - Web.