Slow response time and service interruption

Incident Report for SavvyMoney

Resolved

AWS has resolved the earlier issue in the US-EAST-1 (North Virginia) region that caused elevated error rates and latency across several core services.

Between October 19 at 11:49 PM PDT and October 20 at 3:01 PM PDT, AWS experienced a regional service disruption triggered by a DNS resolution issue affecting DynamoDB, which later caused cascading performance impacts to EC2, Lambda, and other dependent services. These issues led to degraded performance and temporary throttling of some operations across AWS-hosted systems.

As a result, certain SavvyMoney features—such as credit score updates, lending and deposit service integrations, and partner connections with TransUnion, Salesforce, and other integrations—were temporarily affected.

All services have now fully recovered, and AWS has restored normal operations. We have verified that:
— SavvyMoney’s core systems are stable and operational.
— No data loss or security incidents occurred.
— Partner and third-party integrations have returned to normal performance.

Our engineering and DevOps teams continue to monitor AWS and third-party performance closely while AWS finalizes its post-incident review.

Thank you for your patience and understanding during this global disruption.
Posted Oct 20, 2025 - 15:01 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:41 PDT

Update

Incident: AWS Service Degradation Affecting Third-Party Integrations

We are currently responding to a global outage affecting AWS, originating in the US-EAST-1 (Northern Virginia) region, which has caused elevated error rates and latencies across multiple core services.

As a result, several third-party providers and integration partners connected to the SavvyMoney platform — including TransUnion, Salesforce, Atlassian, NADA, and Zest — are experiencing intermittent service degradation.

Our engineering and operations teams are actively monitoring the incident, coordinating with AWS and all affected third-party vendors, and assessing any direct impact to the SavvyMoney platform features (credit score updates, alert delivery, analytics dashboards, loan/offers flows).

Impact Summary:
- Lending and Deposit Services: Users may experience slower response times or intermittent errors when accessing pre-qualified offers or deposit-related insights.
- Credit Data & Partner Integrations: Some credit score updates, loan analytics, and external API calls may be delayed or unavailable.
- Platform Performance: General latency may occur across portions of the application that rely on AWS services such as compute, S3 storage, and API Gateway.

What we know so far:
- The issue appears rooted in AWS internal subsystems (not reported as a cyber-attack).
- Wide-area knock-on effects have been reported — gaming, financial, social, and enterprise platforms all affected.
- AWS has confirmed increased error/latency rates and begun mitigation steps; full recovery timeline is not yet confirmed.

What this means for you:
- Some services of ours may be slower, experience time-outs or delays — especially integrations that pass through AWS infrastructure.
- At present, we are not aware of data loss or compromise of consumer data within the SavvyMoney platform.
- We will track and normalize as soon as AWS signals full recovery and our third-party providers verify stable operation.

Updates:
We will publish further status updates as we receive additional information from AWS and our vendor partners, and once we have completed an internal impact assessment.
Posted Oct 20, 2025 - 09:37 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:36 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:42 PDT

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 07:24 PDT
This incident affected: API Core Service, Analytics, Credit Service, Offers Engine, SSO Service - Auth, SSO Service - Web, SFTP Pipeline, CMS Core Services, CMS Builder Services, AWS - East Coast Region, Lending Digital Journey, Deposits Digital Journey, Lending and Deposits Backoffice/Admin System, Lending & Deposits - API Service, and Lending & Deposits - Site to Site VPN.