Planned SavvyMoney platform updates

Scheduled for Jul 1, 23:00 PDT  -  Jul 2, 03:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 24, 2026 - 03:16 PDT

Scheduled

We will be under maintenance during mentioned time frame (extended window)
Posted Jun 24, 2026 - 03:16 PDT
This scheduled maintenance affects: API Core Service and Credit Service.