Major API Failures – Credit Score Services

Incident Report for SavvyMoney

Resolved

The engineering team has resolved the issue.
Posted Dec 15, 2025 - 13:26 PST

Identified

We have identified the source of the elevated failure rates impacting Credit Score APIs and are monitoring recovery. Error rates are decreasing, and traffic is beginning to stabilize. We continue to work closely with our partners to ensure complete service restoration.

Further updates will be posted as progress continues.
Posted Dec 15, 2025 - 11:57 PST

Investigating

We are investigating a significant service disruption affecting the SavvyMoney Credit Score APIs, with elevated error rates and traffic drops; some integrations are experiencing up to 100% request failures.

Our engineering team is actively working with our integration partners to identify the root cause and restore service.

We will provide updates as more information becomes available.
Posted Dec 15, 2025 - 11:52 PST
This incident affected: API Core Service.