Performance Degradation Impacting External API Services and Credit Score Functionality

Incident Report for SavvyMoney

Resolved

We have resolved the application's slowness. All systems are operating normally. Our team will review the incident and evaluate any changes needed to prevent future occurrences. A complete Root Cause Analysis (RCA) will be published by the end of the week.
Posted Sep 02, 2025 - 10:52 PDT

Update

We have resolved the performance degradation affecting external API services. All API functionality is now operating normally. However, some users may continue to experience slowness in the user interface. Our engineering team is actively working to remediate the remaining issues and will provide further updates as progress is made.
Posted Sep 02, 2025 - 10:34 PDT

Identified

We have identified the root cause of the performance degradation impacting external API services and credit score functionality. Our engineering team is deploying a solution and code update to remediate the issue. Some users may continue to experience slowness during this process. We will provide another update once the deployment is complete and performance is fully restored.
Posted Sep 02, 2025 - 09:59 PDT

Investigating

We are investigating performance degradation reports affecting external API services and credit score functionality. Our engineering team is actively working to identify the cause and will provide updates as more information becomes available.
Posted Sep 02, 2025 - 09:11 PDT
This incident affected: API Core Service and Credit Service.